Bass Fishing Forum Bass Fishing Forum

Site Slogan

News: NEW FORUM! Yes, this is UB! Feedback HERE!

Daiwa Ballistic LT 4000 spinning reel drag issue

(Read 376 times)

0 Members and 1 Guest are viewing this topic.


BECOME A CHARTER MEMBER SUPPORT UB

apenland01

  • Charter Member
  • *****
  • Posts: 1,181
  • Location: Tucson Arizona
  • Baby Bass
I have used this reel a handful of times since I got it a few months ago.  I'm experimenting with a new braid and got it spooled up without any issue.  I went to use it this weekend for a tournament and the drag wasn't working.

It didn't matter how tight I screwed down the drag, the spool would turn and there wasn't any clicking sound.  I quickly took the spool off and didn't see anything obvious, but it never did work right.  I didn't have time to mess with it, so I switched reels out.

I forgot it on the boat, but I'll be able to work on it next weekend.  What do I need to check for on the drag?  Should I just disassemble it and put it back together?

It is still under warranty, but I would rather just figure it out if I can.....


Mike Cork

  • Father Time
  • Admin
  • ***
  • Posts: 74,138
  • Location: NW Louisiana
  • Gender: Male
  • Get the Net it's a Hawg
Because there was no clicking sound I'm 99 percent sure the braid is spinning on your spool. Take the line off in the yard or something so you don't waste it and when you get to the end, put a small piece of tape on the line and spool. Then Spool back up and this will fix it. Happens on bait casters as well
Fishing is more than just a hobby

Dobyns Rods - Monster Fishing Tackle
Cork's Reel Service

 


BECOME A CHARTER MEMBER SUPPORT UB